A proposito dell'autore

Da aggiornare.

Introduzione

Anche con l’assenza di una vera e propria linea isdn è possibile configurare e testare la connettività Bri tra 2 o più router Cisco. Questo è realizzabile grazie a un simulatore ISDN (facilmente acquistabile in rete) che come dice la parola stessa ci permette di simulare 2 o piu linee ISDN direttamente a casa nostra, dandoci la possibilità di essere certi che la connettività tra i nostri nodi sia perfettamente funzionante (senza spendere un centesimo per le prove).

Attenzione: il simulatore ISDN non è configurabile: fare quindi attenzione all’assegnazione delle porte.

Mettiamoci al lavoro

Dopo aver collegato i cavi console colleghiamo i cavi rj45 dall’interfaccia BRI al simulatore, facendo attenzione nel collegare il cavo rj45 nella porta chiamante del simulatore e viceversa. A questo punto accendiamo i router e configuriamoli, logicamente, dandogli un nome e inserendo user e password per l’autentiazione:

Router#conf ter
Router(config)#hostname Palermo
Palermo(config)#username Milano password cisco
Router#conf ter
Router(config)#hostname Milano
Milano(config)#username Palermo password cisco

Adesso assegniamo gli indirizzi ip,l’incapsulazione e l’autenticazione di tipo chap alle interfacce:

Palermo(config)#interface bri0
Palermo(config-if)#ip address 10.0.0.1 255.255.255.252
Palermo(config-if)#encapsulation ppp
Palermo(config-if)#ppp authenication chap
Milano(config)#interface bri0
Milano(config-if)#ip address 10.0.0.2 255.255.255.252
Milano(config-if)#encapsulation ppp
Milano(config-if)#ppp authenication chap

A queso punto procediamo con la configurazione del dialer-group e dialer map per effettuare la chiamata:

Palermo(config-if)#dialer-group 1
Palermo(config-if)#dialer map ip 10.0.0.2 broadcast 21
Milano(config-if)#dialer-group 1
Milano(config-if)#dialer map ip 10.0.0.1 broadcast 16

Da notare che in questo esempio i numeri 21-16 sono corrispondenti al rispettivo numero allocato nel simulatore, ma nella realtà non saranno altro che i numeri telefonici dei rispettivi chiamanti.

Fatto questo basta anche un ping per far partire la chiamata verso l’altro router e accertarsi della connettività con comandi di tipo: sh isdn active, sh isdn staus o interface bri 0

Palermo#ping 10.0.0.2
!!! Success rate is 100 percet 5/5
Milano#ping 10.0.0.1
!!! Success rate is 100 percet 5/5

Infine, se lo si vuole, la possibilità di associare un access-list a una dialer list; Infatti in questo esempio, si consente solamente a un servizio di tipo telnet di poter agire a chiamata effettuata:

Palermo(config)#access-list 100 permit tcp any host 10.0.0.2 eq telnet
Palermo(config)#dialer-list 1 protocol ip list 100
Milano(config)#access-list 100 permit tcp any host 10.0.0.2 eq telnet
Milano(config)#dialer-list 1 protocol ip list 100

N.B. Ricordate di configurare almeno una delle 5 sessioni di telnet:

Palermo(config)#line vty 0
Palermo(config-line)# password cisco
Palermo(config-line)#login  
Milano(config)#line vty 0
Milano(config-line)# password cisco
Milano(config-line)#login

Post correlati

Close
Entra in contatto con altri professionisti ICT, seguici su Facebook e Twitter: