A proposito dell'autore

Ciao a tutti, sono Alessandro, sono nato a Palermo il 24/01/1983 e vivo a qualche chilometro dalla città. Da anni coltivo la passione per i computer e tutto quello che ci sta attorno, con un occhio di riguardo per il mondo delle reti. Nel 2000 mi avvicino al mondo di Linux e ne resto impressionato da ciò che consente di fare, nonchè alla filosofia dell’opensource. Nel Aprile 2005 ho conseguito la certificazione Cisco CCNA. Da Novembre 2006 sono membro del CUG. Ho completato il corso HP IT Essential I e II e Cisco Network Security. Ho svolto uno stage presso Jump2Future dove mi sono occupato di redigere una ralazione per la realizzazione di un cluster basato su RedHat GFS (Global File System). Lavoro per l’IBIM-CNR di Palermo dal 2002 come tecnico informatico e gestione rete. Sto cominciando ad acquisire conoscenze nel campo del VoIP con software quali Trixbox e Elastix, realizzazione e uso di macchine virtuali basate su VMWare.

Di seguito riporto un esempio di configurazione per router Cisco 827 con connessione Telecom Alice 7Mbit.

version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname c827
!
boot-start-marker
boot-end-marker
!
enable secret xxxxxxxxxxxxxxxxxx
!
no aaa new-model
ip subnet-zero
no ip domain lookup
ip name-server 151.99.125.2
ip name-server 212.216.112.112
ip dhcp excluded-address 192.168.0.1 192.168.0.5
!
ip dhcp pool LAN
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 151.99.125.2 212.216.112.112
   domain-name alessandro-pensato.it
lease 0 12
!
!
interface Ethernet0
   description Interfaccia Ethernet0/0 - Lan interna
   ip address 192.168.0.1 255.255.255.0
   ip nat inside
   hold-queue 100 out
!
interface ATM0
   description Interfaccia ATM0/0 - Connessione ADSL
   no ip address
   no atm ilmi-keepalive
   pvc 8/35
       encapsulation aal5mux ppp dialer
       dialer pool-member 1
!
   dsl operating-mode ansi-dmt
   hold-queue 224 in
!
interface Dialer0
   description Interfaccia Dialer0/0 - Alice ADSL Flat 7Mega
   ip address negotiated
   ip nat outside
   encapsulation ppp
   dialer pool 1
   ppp authentication chap callin
   ppp pap sent-username aliceadsl password 7 050A0A0622494F0D0A09
!
ip nat translation timeout 420
ip nat translation tcp-timeout 120
ip nat translation pptp-timeout 420
ip nat translation icmp-timeout 1
ip nat translation max-entries 1000
ip nat inside source list 1 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
line con 0
   logging synchronous
   transport preferred all
   transport output all
   stopbits 1
line vty 0 4
   access-class 1 in
   password xxxxxxxxxxxxxxxxxx
   logging synchronous
   login
   transport preferred all
   transport input all
   transport output all
!
scheduler max-task-time 5000
!
end

Post correlati

Close
Entra in contatto con altri professionisti ICT, seguici su Facebook e Twitter: