A proposito dell'autore

Ciao a tutti, sono Alessandro, sono nato a Palermo il 24/01/1983 e vivo a qualche chilometro dalla città. Da anni coltivo la passione per i computer e tutto quello che ci sta attorno, con un occhio di riguardo per il mondo delle reti. Nel 2000 mi avvicino al mondo di Linux e ne resto impressionato da ciò che consente di fare, nonchè alla filosofia dell’opensource. Nel Aprile 2005 ho conseguito la certificazione Cisco CCNA. Da Novembre 2006 sono membro del CUG. Ho completato il corso HP IT Essential I e II e Cisco Network Security. Ho svolto uno stage presso Jump2Future dove mi sono occupato di redigere una ralazione per la realizzazione di un cluster basato su RedHat GFS (Global File System). Lavoro per l’IBIM-CNR di Palermo dal 2002 come tecnico informatico e gestione rete. Sto cominciando ad acquisire conoscenze nel campo del VoIP con software quali Trixbox e Elastix, realizzazione e uso di macchine virtuali basate su VMWare.

Di seguito riporto un esempio di configurazione PPPoE per router Cisco 827 con connessione Telecom Alice 7Mbit.

version 12.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname c827
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip subnet-zero
ip name-server 151.99.125.2
ip name-server 212.216.112.112
ip dhcp excluded-address 192.168.0.100
ip dhcp excluded-address 192.168.0.1 192.168.0.5
!
ip dhcp pool LAN
  network 192.168.0.0 255.255.255.0
  default-router 192.168.0.1
  dns-server 208.67.222.222 151.99.0.100
  lease 0 12
!
no ip bootp server
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
interface Ethernet0
description Interfaccia Ethernet0/0 - Lan interna
ip address 192.168.0.1 255.255.255.0
no ip redirects
ip mtu 1492
ip nat inside
ip tcp adjust-mss 1452
no cdp enable
hold-queue 100 out
!
interface ATM0
description Interfaccia ATM0/0 - Connessione ADSL
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
hold-queue 224 in
pvc 8/35
 pppoe-client dial-pool-number 1
 !
!
interface Dialer0
description Interfaccia Dialer0/0 - Alice Mega ADSL 7Mbit/s
bandwidth 8096
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp header-compression passive
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username aliceadsl password 0 aliceadsl
!
ip nat translation timeout 420
ip nat translation syn-timeout 40
ip nat translation max-entries 5000
ip nat inside source list 1 interface Dialer0 overload
ip classless
no ip forward-protocol udp bootps
no ip forward-protocol udp tftp
no ip forward-protocol udp nameserver
no ip forward-protocol udp domain
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
access-list 1 permit 192.168.0.0 0.0.0.255
banner login ^C
                 ||        ||
                 ||        ||
                ||||      ||||
            ..:||||||:..:||||||:..
              Cisco Systems Inc.
                       -
              c827 @ 192.168.0.1

*** Accesso alla configurazione del router. Ogni accesso viene loggato ***^C
banner prompt-timeout ^C
La sessione di lavoro e' scaduta. Per continuare e' necessario
riautenticarsi.^C
!
line con 0
transport preferred all
transport output all
stopbits 1
line vty 0 4
access-class 1 in
exec-timeout 0 0
logging synchronous
login
transport preferred all
transport input all
transport output all
!
scheduler max-task-time 5000
sntp server 193.204.114.232
sntp server 193.204.114.233
end
Close
Entra in contatto con altri professionisti ICT, seguici su Facebook e Twitter: