A proposito dell'autore

Ciao a tutti, sono Alessandro, sono nato a Palermo il 24/01/1983 e vivo a qualche chilometro dalla città. Da anni coltivo la passione per i computer e tutto quello che ci sta attorno, con un occhio di riguardo per il mondo delle reti. Nel 2000 mi avvicino al mondo di Linux e ne resto impressionato da ciò che consente di fare, nonchè alla filosofia dell’opensource. Nel Aprile 2005 ho conseguito la certificazione Cisco CCNA. Da Novembre 2006 sono membro del CUG. Ho completato il corso HP IT Essential I e II e Cisco Network Security. Ho svolto uno stage presso Jump2Future dove mi sono occupato di redigere una ralazione per la realizzazione di un cluster basato su RedHat GFS (Global File System). Lavoro per l’IBIM-CNR di Palermo dal 2002 come tecnico informatico e gestione rete. Sto cominciando ad acquisire conoscenze nel campo del VoIP con software quali Trixbox e Elastix, realizzazione e uso di macchine virtuali basate su VMWare.

Premessa

Questo laboratorio è indirizzato a tutti coloro che hanno raggiunto la fine del quarto semestre del percorso di certificazione CCNA. Infatti, come si può leggere negli obiettivi, tale laboratorio prevede l’applicazione delle varie tecnologie WAN descritte nel curriculum del quarto semestre, ma anche argomenti affrontati nei semestri precedenti.

Topologia

Topologia LAB

Materiale occorrente

Per la realizzazione di questa esercitazione occorre quanto segue:

  • 2 router con interfaccia Ethernet e seriale
  • 1 router con 2 interfaccie seriali e una Ethernet
  • 3 computer per la configurazione di ciascun router e come host per i test
  • 3 cavi console
  • 3 cavi crossover RJ45
  • 2 cavi crossover DCE/DTE (oppure cavi DCE e DTE separati)

Obiettivi

Tale esercitazione prevede:

  • Configurazione di base dei router
  • Configurazione del Frame Relay
  • Configurazione del PPP
  • Configurazione del Chap
  • Configurazione del DHCP
  • Configurazione del NAT
  • Configurazione di ACL
  • Configurazione del EIGRP
  • Configurazione di Route statiche
  • Redistribuzione di Route

Su tutti i router la Serial0/0 sarà configurata come DCE con clockrate pari a 64000, mentre la Serial0/1 come DTE.

Configurazione del router ISP

en
conf t
hostname ISP
enable secret class 

int fa0
ip address 10.0.0.1 255.255.255.0
ip nat outside
no shut
exit 

int s0
encapsulation frame-relay ietf
bandwith 64
frame-relay interface-dlci 16
frame-relay map ip 192.168.0.6 16 broadcast ietf
frame-relay lmi-type ansi
ip address 192.168.0.5 255.255.255.252
no keepalive
no shut
ip nat inside
exit 

line con 0
password cisco
login
exit

line vty 0 4
password cisco
login
exit   

ip dhcp excluded-address 10.0.0.1 10.10.0.10
ip dhcp pool LAN
network 10.0.0.0 /24
default-router 10.0.0.1
dns-server 10.0.0.2
domain-name test.org
exit

access-list 1 permit 10.0.0.0 0.0.0.255
ip nat pool public 200.0.0.1 200.0.0.20 netmask 255.255.255.0
ip nat inside source list 1 pool public overload
ip route 192.168.1.0 0.0.0.3 192.168.0.6
ip route 172.16.4.0 0.0.0.255 192.168.0.6
ip route 172.16.5.0 0.0.0.255 192.168.0.6

Configurazione del router Milano

en
conf t
hostname Milano
enable secret class
username Padova password cisco

int s0
encapsulation frame-relay ietf
bandwith 64
clock rate 64000
frame-relay interface-dlci 16
frame-relay map ip 192.168.0.5 16 broadcast ietf
frame-relay lmi-type ansi
ip address 192.168.0.6 255.255.255.252
no keepalive
no shut
exit

int s1
encapsulation ppp
ppp authentication chap
ip address 192.168.1.1 255.255.255.252
no keepalive
no shut
exit

int fa0
ip address 176.16.4.1 255.255.255.0
no shut 
exit

line con 0
password cisco
login
exit 

line vty 0 4
password cisco
login
exit

router eigrp 100
network 172.16.4.0
network 192.168.1.0
redistrute static
redistribute connected
exit

ip route 0.0.0.0 0.0.0.0 192.168.0.5

Configurazione del router Padova

en
conf t
hostname Padova
enable secret class
username Milano password cisco

int s0
encapsulation ppp
ppp authentication chap
ip address 192.168.0.2 255.255.255.252
no keepalive
no shut
bandwidth 64
cloack rate 64000
exit

int fa0
ip address 176.16.5.1 255.255.255.0
no shut 
exit 

line con 0
password cisco
login
exit

line vty 0 4
password cisco
login
exit

router eigrp 100
network 172.16.5.0
network 192.168.1.0
exit

Verifica delle configurazioni

Giunti a questo punto, possiamo effettuare le operazioni di verifica

  • Corretta configurazione degli host (IP da DHCP e Manuale)
  • Dai router ISP, Milano e Padova si devono pingare tutte le interfaccie dei router e host
  • Sui router Milano e Padova si devono vedere le varie reti imparate tramite EIGRP
  • Sul router ISP abilitare il debug ip packet per avere informazioni sul funzionamento del NAT
  • Sui router Milano e ISP usare il comando show frame-relay e debug frame-relay con le relative opzioni per avere informazioni sul collegamento Frame Relay.

Post correlati

Close
Entra in contatto con altri professionisti ICT, seguici su Facebook e Twitter: