A proposito dell'autore

Attualmente gestisce la parte tecnica del progetto FoolDns, segue la parte sistemistica in qualità di consulente del portale per artisti dammispazio.com, gestisce la rete e le macchine per l'ISP campano IrpiniaNet com. Oth info: http://www.marocchio.com


Mikrotik è una meta-distribuzione Linux che include una shell customizzata e una GUI per sistemi Win32. E’ una distrubuzione famosa sopratutto per il Wireless, recentemente si è addentrata molto nel routing e anche nel mercato “small ISP” con i suoi prodotti per core router. Recentemente ha incluso  anche il supporto (seppur parziale) a MPLS.

OSPF è un protocollo Link state vector utilizzato per il routing all’interno di un AS.
Non ci addentreremo ulteriormente all’interno del protocollo e del suo funzionamento.

True case

Oggi porteremo una semplice rete, che sino ad ora era gestita con route statiche ad OSPF. La seguente rete è il backbone di un’infrastruttura Wireles metropolitana che copre una piccola città e paesi limitrofi, il numero di utenti collegati è di poco piu’ di un migliaio.

La rete è totalmente IP, non vi sono sistemi di AAA (es: PPPoE). Tutti gli IP della rete sono statici (compresi quelli dei clienti).

Il passaggio a OSPF è stato necessario in seguito alla necessità di ridondare ogni singolo apparato di backbone. La struttura attuale della rete è riportata in Fig1.Fig.1
colori diversi denotano sottoreti diverse.
Colore nero = 10.10.0.0/27
Colore viola = 10.10.0.32/28
Colore giallo = 10.10.0.48/28
Colore verde = 10.10.0.64/28

Tutti i router detengono una default route manualmente inserita in fase di setup e le rotte delle singole reti assegnati ai router “in cascata” vengono aggiunte manualmente ad ogni modifica della rete. Questo in svariati casi, a seguito di errore dell’operatore, ha portato a down parziali dell’infrastruttura. Questi piccoli inconvenienti, uniti  al bisogno di affidabilità, hanno portato al passaggio ad OSPF.

OSPF sul core

Attiviamo l’istanza di OSPF:

/routing ospf instance
set default comment="" disabled=no distribute-default=always-as-type-1 router-id=10.10.0.1

Modifichiamo l’area di default e aggiungiamo l’area dei clienti:

/routing ospf area
set backbone area-id=0.0.0.0 disabled=no instance=default name=backbone type=default
add name=clients area-id=0.0.0.1

Attiviamo l’autenticazione sull’interfaccia usata da OSPF:

/routing ospf interface
add authentication=md5 authentication-key=secret authentication-key-id=1 cost=10 dead-interval=40s disabled=no hello-interval=10s instance-id=0 interface=ether2 network-type=broadcast passive=no

Aggiungiamo le sottoreti alle aree relative:

/routing ospf network
add area=backbone disabled=no network=10.10.0.0/25
add area=clients disabled=no network= 10.10.1.0/24
add area=clients disabled=no network=10.10.2.0/23
add area=clients disabled=no network=10.10.4.0/23

in questa maniera abbiamo  “separato” le reti dei clienti dalle reti di backbone.

OSPF su un router di frontiera

Attiviamo l’istanza di OSPF:

/routing ospf instance
set default comment="" disabled=no metric-connected=20 metric-default=1 metric-static=20  redistribute-connected=as-type-1  redistribute-static=as-type-1 router-id=10.10.0.6

Aggiungiamo l’area per i clienti ( oltre alla backbone già presente )

/routing ospf area
set backbone area-id=0.0.0.0 disabled=no
add area-id=0.0.0.1 default-cost=1 disabled=no instance=default name=clients  type=stub

Sistemiamo l’autenticazione per l’intefaccia verso area di backbone:

/routing ospf interface
add authentication=md5 authentication-key=secret authentication-key-id=1 cost=10 instance-id=0 interface=ether1 network-type=broadcast priority=1

Aggiungiamo le reti alle aree rispettive:

/routing ospf network
add area=backbone disabled=no network=10.10.0.0/24
add area=clients disabled=no network= 10.10.1.0/24
add area=clients disabled=no network=10.10.2.0/23
add area=clients disabled=no network=10.10.4.0/23

Ora il router appena configurato importerà la default-route dal core-router e a sua volta esporterà le reti a esso connesse e le rotte statiche che ha inserito.
Modificando uno per volta i router della rete si otterrà una rete OSPF. Una volta che OSPF sarà attivo su tutti i router è possibile rimuovere tutte le rotte statiche presenti (a meno che non siano necessarie!).

Ridondanza dei link

Con il passaggio a OSPF si è deciso di ridondare alcuni link, chiudendo sostanzialmente gli anelli della rete (ove possibile).

La struttura della rete finale è riportata in Figura 2. I link tratteggiatifig22 sono quelli di backup. Ad un occhio esperto sicuramente salterà all’occhio che i nuovi link se inseriti nella rete senza le dovute “precauzioni” diventerebbero automaticamente attivi. OSPF ragiona a pesi per interfaccia.

ES: se il link tratteggiato color ocra non avesse almeno peso “41” da entrambi i lati diventerebbe automaticamente attivo escludendo il percorso originale.

Questo modo di agire di OSPF ci da quindi la possibilità di bilanciare link, uno usato per l’upstream, uno per il downstream, o di aggregarli grezzamente per entrambe le direzioni a livello di routing.

That’s all folks (per questa volta).

Close
Entra in contatto con altri professionisti ICT, seguici su Facebook e Twitter: