venerdì, Aprile 19, 2024

Case Study CCNA4: Wans

Alessandro Pensato
Alessandro Pensatohttp://www.alessandro-pensato.it
Ciao a tutti, sono Alessandro, sono nato a Palermo il 24/01/1983 e vivo a qualche chilometro dalla città. Da anni coltivo la passione per i computer e tutto quello che ci sta attorno, con un occhio di riguardo per il mondo delle reti. Nel 2000 mi avvicino al mondo di Linux e ne resto impressionato da ciò che consente di fare, nonchè alla filosofia dell’opensource. Nel Aprile 2005 ho conseguito la certificazione Cisco CCNA. Da Novembre 2006 sono membro del CUG. Ho completato il corso HP IT Essential I e II e Cisco Network Security. Ho svolto uno stage presso Jump2Future dove mi sono occupato di redigere una ralazione per la realizzazione di un cluster basato su RedHat GFS (Global File System). Lavoro per l’IBIM-CNR di Palermo dal 2002 come tecnico informatico e gestione rete. Sto cominciando ad acquisire conoscenze nel campo del VoIP con software quali Trixbox e Elastix, realizzazione e uso di macchine virtuali basate su VMWare.

Fase 1 – Indirizzamento IP

Fase 2 – Configurazione dei Router e OSPF

Configurazione Router Limerick

enable
conf t 
hostname Limerick
banner motd # Router Limerick - Accesso limitato #

line console 0
password cisco
login
exit

line vty 0 4
password cisco
login
exit

enable secret class
ip subnet-zero
 
int lo0
ip address 10.10.10.252 255.255.255.255
description Interfaccia Loopback0/0 – ID OSPF
no shutdown
exit

int s0
ip address 172.16.8.245 255.255.255.252
description Interfaccia Serial0/0 – DCE verso Belfast Serial0/1
clock rate 2000000
ip ospf message-digest-key 1 md5 7 ospfauth
no shutdown
exit

router ospf 1
network 10.10.10.0 0.0.0.255 area 0
network 172.16.8.244 0.0.0.3 area 0
area 0 authentication message-digest
exit

Configurazione Router Belfast

enable
conf t
hostname Belfast
banner motd # Router Belfast - Accesso limitato #

line console 0
password cisco
login
exit

line vty 0 4
password cisco
login
exit

enable secret class
ip subnet-zero

access-list 1 permit 172.16.0.0 0.0.255.255
access-list 1 deny any

ip nat pool public 192.168.1.6 192.168.1.6 netmask 255.255.255.252
ip nat source list 1 pool public overload
ip nat translation timeout 120
int lo0

ip address 10.10.10.254 255.255.255.255
description Interfaccia Loopback0/0 – ID OSPF
no shutdown
exit

int s0
ip address 172.16.8.241 255.255.255.252
description Interfaccia Serial0/0 – DCE verso Cork Serial0/1
clock rate 2000000
ip ospf message-digest-key 1 md5 7 ospfauth
ip nat inside
no shutdown
exit

int s1
ip address 172.16.8.246 255.255.255.252 
description Interfaccia Serial0/1 – DTE verso Limerick Serial0/0
ip ospf message-digest-key 1 md5 7 ospfauth
ip nat inside
no shutdown
exit

int e0
ip address 10.0.0.1 255.0.0.0
description Interfaccia Ethernet0/0 – Connessione verso ISP
ip nat outside
no shutdown
exit

router ospf 1
network 10.10.10.0 0.0.0.255 area 0
network 172.16.8.240 0.0.0.3 area 0
network 172.16.8.244 0.0.0.3 area 0
default-information originate
area 0 authentication message-digest
exit

ip route 0.0.0.0 0.0.0.0 e0

Configurazione Router Cork

enable
conf t
hostname Cork
banner motd # Router Cork - Accesso limitato #

line console 0
password cisco
login
exit

line vty 0 4
password cisco
login
exit

enable secret class
ip subnet-zero

int lo0
ip address 10.10.10.253 255.255.255.255
description Interfaccia Loopback0/0 – ID OSPF
no shutdown
exit

int s1
ip address 172.16.8.242 255.255.255.252
description Interfaccia Serial0/1 – DTE verso Belfast Serial0/0
ip ospf message-digest-key 1 md5 7 ospfauth
no shutdown
exit

int s0
ip address 172.16.8.249 255.255.255.252
description Interfaccia Serial0/0 – DTE verso FrameRelay
encapsulation frame-relay
frame-relay inverse-arp
frame-relay local-dlci 16
frame-relay map ip 172.16.8.250 17 broadcast
bandwidth 64
no shutdown
exit

int e1.1
encapsulation dot1Q
ip address 172.16.4.1 255.255.255.0
description Interfaccia Ethernet0/1.1 – Gateway per VLAN1
no shutdown
exit

int e1.2
encapsulation dot1Q
ip address 172.16.5.1 255.255.255.0
description Interfaccia Ethernet0/1.2 – Gateway per VLAN2
no shutdown
exit

int e1.3
encapsulation dot1Q
ip address 172.16.6.1 255.255.255.0
description Interfaccia Ethernet0/1.3 – Gateway per VLAN3
no shutdown
exit

router ospf 1
network 10.10.10.0 0.0.0.255 area 0
network 172.16.8.240 0.0.0.3 area 0
network 172.16.4.0 0.0.0.255 area 0
network 172.16.5.0 0.0.0.255 area 0
network 172.16.6.0 0.0.0.255 area 0
area 0 authentication message-digest
redistribute rip subnets
exit

router rip
version 2
network 172.16.8.248 
redistribute ospf 1 match internal external 1 external 2
default-metric 17

Configurazione Router Galway

enable
conf t
hostname Galway
banner motd # Router Galway - Accesso limitato #

line console 0
password cisco
login
exit

line vty 0 4
password cisco
login
exit

enable secret class
ip subnet-zero

int s0
ip address 172.16.8.250 255.255.255.252
description Interfaccia Serial0/0 – DTE verso FrameRelay
encapsulation frame-relay
frame-relay inverse-arp
frame-relay local-dlci 17
frame-relay map ip 172.16.8.249 16 broadcast
bandwidth 64
no shutdown
exit

int e0
ip address 172.16.0.1 255.255.252.0
description Interfaccia Ethernet0/0 – Gw e Server DHCP per LAN
no shutdown
exit

router rip
version 2
network 172.16.8.248
exit

ip dhcp pool ip_dinamici
network 172.16.0.0 /22
default-router 172.16.0.1
dns-server 172.16.0.2 151.99.125.2 151.99.125.3 212.216.112.112
domain-name development.local
exit

ip dhcp excluded-address 172.16.0.1 172.16.0.2

Fase 3 – Configurazione del NAT, simulazione Frame Relay, creazione ACL

Router Belfast (NAT)

access-list 1 permit 172.16.0.0 0.0.255.255
access-list 1 deny any

ip nat pool public 192.168.1.6 192.168.1.6 netmask 255.255.255.252
ip nat source list 1 pool public overload
ip nat translation timeout 120

int s0
ip address 172.16.8.241 255.255.255.252
description Interfaccia Serial0/0 – DCE verso Cork Serial0/1
clock rate 2000000
ip ospf message-digest-key 1 md5 7 ospfauth
ip nat inside
no shutdown
exit

int s1
ip address 172.16.8.246 255.255.255.252
description Interfaccia Serial0/1 – DTE verso Limerick Serial0/0
ip ospf message-digest-key 1 md5 7 ospfauth
ip nat inside
no shutdown
exit

int e0
ip address 10.0.0.1 255.0.0.0
description Interfaccia Ethernet0/0 – Connessione verso ISP
ip nat outside
no shutdown
exit

Router Crok (Frame Relay)

int s0
ip address 172.16.8.249 255.255.255.252
description Interfaccia Serial0/0 – DTE verso FrameRelay
encapsulation frame-relay frame-relay inverse-arp
frame-relay local-dlci 16
frame-relay map ip 172.16.8.250 17 broadcast
bandwidth 64
no shutdown
exit

Router Galway (Frame Relay)

int s0
ip address 172.16.8.250 255.255.255.252
description Interfaccia Serial0/0 – DTE verso FrameRelay
encapsulation frame-relay 
frame-relay inverse-arp
frame-relay local-dlci 17
frame-relay map ip 172.16.8.249 16 broadcast
bandwidth 64
no shutdown
exit

Router Galway (ACL)

access-list 100 permit 172.16.0.0 0.0.3.255 10.0.0.0 0.255.255.255 eq 80
access-list 100 permit ip any 172.16.0.0 0.0.255.255

Configurazione router come switch Frame Relay

en
conf t
hostname Sw_FR
frame-relay switching

int s0
encapsulation frame-relay
clock rate 64000
bandwidth 64
frame-relay intf-type dce
frame-relay route 17 interface serial 1 16
no shut
exit

int s1
encapsulation frame-relay
clock rate 64000
bandwidth 64
frame-relay intf-type dce
frame-relay route 16 interface serial 0 17
no shut
exit

Fase 4 – Configurazione delle VLAN e DHCP

Configurazione Switch CorkLan

enable
conf t
hostname CorkLan

line console 0
password cisco
login
exit

line vty 0 11
password cisco
login
exit

enable secret class

vlan database
vlan 2
vlan 3
vtp v2-mode
vtp domain Cork
vtp trasparent
exit

int fa0/1
switchport mode trunk
speed 100
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/2
switchport mode access 
switchport access vlan 1
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/3
switchport mode access 
switchport access vlan 1
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/4
switchport mode access 
switchport access vlan 1
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/5
switchport mode access 
switchport access vlan 2
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/6
switchport mode access 
switchport access vlan 2
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/7
switchport mode access 
switchport access vlan 2
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/8
switchport mode access 
switchport access vlan 2
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/9
switchport mode access 
switchport access vlan 3
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/10
switchport mode access 
switchport access vlan 3
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/11
switchport mode access 
switchport access vlan 3
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

int fa0/12
switchport mode access 
switchport access vlan 3
speed 10
duplex full
switchport port-security maximum 1
switchport port-security violation shutdown
exit

Configurazione Router Gateway come server DHCP

ip dhcp pool ip_dinamici
network 172.16.0.2 /22
default-router 172.16.0.1
dns-server 172.16.0.2 151.99.125.2 151.99.125.3 212.216.112.112
domain-name development.local
exit

ip dhcp excluded-address 172.16.0.1 172.16.0.2

Articoli correlati

Non perdere il lancio online della Community GDPR Day: 26 marzo 2024

La sicurezza dei dati e delle informazioni non è più un'opzione, ma una necessità imprescindibile. Lo dimostrano i tanti attacchi informatici che, con frequenza...

Digital Transformation


 

Noleggia una Tesla per il tuo evento ICT!

Categorie